Personal View site logo
Official TZ10 Hack Project Discussion
  • 134 Replies sorted by
  • I am having problem with loading the hack firmware. I am on the second screen of 'version up ongoing' but no status bar. After about ten seconds, it went back to start version up?. Are all zs7's hackable?
  • @tody
    No progress bar. After firmware upgrade, camera restarts. Since the hack SD card is still in the camera, it prompts you to upgrade (again). Just say "no," shut down camera, replace firmware SD card with picture SD card, restart and test.
  • ah! the camera firmware is still 1.2 but the hack was applied as I can see multi languages screen. thx!
  • @Vitaliy: I noticed that with this firmware hack, my ability to do a custom WB seems to have disappeared. I cannot get the camera to do a custom WB. When setting a custom WB, the option is there, but no box area for picking a WB. Instead the camera exits the menu. Did you experience this with your test cameras?
  • Hello my friends and dear vitaly!
    It is possible to have romanian language in this tz10,also a preset bin with some values who working with a standard sdhc class6?
    Maybe somebody make some test and we give some coocked healty strong and reliable bin!
    Thank you!
  • >Maybe somebody make some test and we give some coocked healty strong and reliable bin!

    No one here will give you "coocked healty strong and reliable bin".
    So, spend some time reading and make your own.
  • Fantastic! Looking forward to using camera in English finally. Donated, cheers.

  • any chance the hack will be also for the Panasonic Lumix DMC-FT1 / TS1 underwater camera?

    specs should be pretty similar...
  • @underwater

    May be TS3 in the future, if enough people will be interested.
  • Worked like a charm, my Japanese TZ10 now has English, perfect.

    But did you have to use delphi, it is a real pain to trace :)
  • Hi guys,

    Just v quickly been researching a problem and came across this site.

    I bought a TZ20 and on holiday got it a bit wet - after drying it out completely, it did seem to work fine for a bit but now I am getting the "this battery cannot be used" msg. The battery seems fine, as it turns the camera on fine etc etc, but from research looks like the ID of the battery may have failed or the sensor in the camera has.

    I will be taking the camera back etc etc, but in the mean time wanted to find out if the TZ20 has been hacked? I am guessing not as I cannot find a topic on this here?

    I guess if the firmware is hackable, the check should be able to be skipped?

    Many thanks
  • Hi there,

    First of all thanks for the hack! I want to buy a tz10 today and do some tests. Question: can I use Ptool 3.62d for the tz10 or do i need to use 3.60?


  • @Gerondo

    How about try first, before asking question :-) ?
  • Great job man!

    Would be really nice if you can set better value of dynamic audio compression. I'm not talking about codecs, but this:
    If you recorded a video in a rock gig with TZ10 you know it. Audio sounds distorted and compression or volume limiter works wrong. We need of more compression in a louder volume scenario (like concerts).

    Thanks for your work!
  • >We need of more compression in a louder volume scenario (like concerts).

    You need proper external recorder, believe me.
  • Mm ok that's the best way, but I don't need a great result, I need it decent.
    As I know, listening to my video, there's a limiter/compressor and this should be set in some way. I don't know if this is something you can set in firmware or it's hardly coded somewhere else, audio chip and similar.
  • Hey - just got a GH2 so I can apply your amazing hack (waiting for fast SD card to arrive). Seen some amazing results on Vimeo. But now I see I can tdo the same for my TZ10. Awesome! Just donated more money. Where can I get the TZ10 base firmware - there has to a be a link here somewhere? Thanks
  • @burgor57
    "tz10 firmware", Google, first result.
  • Thanks Vitaliy. Big thanks to you and others for doing this work. Am about to take the plunge myself for the first time with the hack - got my GH2 yesterday. Can I ask you - first I tried to open my saved Firmware update file (created with your PTool3) in the PTool3 app - but it won't do that because it's an already patched file. So if I want to get back to factory default firmware, do I open the original firmware in Ptool3 and then save out as a new version to load into the camera? Is that how it's done? Why can't we open saved patch files to edit and save out from that?

  • LX5 Firmware update tomorrow! It is going to be a BIG one they say!!

    Anyone know of what this is about
  • @Vitaliy_Kiselev

    >How about try first, before asking question :-) ?

    bought a tz10 today and applied hack but I see no difference in quality at all. All I did was choose version increment and avchd compression bitrate SH 32000000 and overall bitrate of 52000000. Maybe I did something wrong, but I have experience with GH2 Hack (which is awesome, thank you so much for that!) so I do not understand. Please help
  • @Gerondo

    You need to use GH1 hacks, not GH2 ones :-)
    And it behaves differently to GH2.
  • Ah! Thanks. On my way : )