Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
PTool 3.56d topic
  • 98 Replies sorted by
  • Wait! I've made it work! I'm not sure how but I have. I saved the file as GH1_133.bin and set the version increment to 21...not sure why this worked but it did.
  • Ugh....my battery wasn't that low, 2/3rds charged, but now I'm just staring at the green led watching it charge....oh vel, just moved so I need to setup my main computer anyway, back in an hr or so.
  • You should get a second battery and always have one "ready for action" :)
  • Same settings for 480p as for lpowell's 50Mbps MJPEG 4:2:2
    E1 Quality=225
    E1 Table=96
    E2 Quality=195
    E2 Table=48
    E3 Quality=170
    E3 Table=16
    E4 Quality=150
    E4 Table=4

    480p mode has visibly more noise and sharpening compared to HD MJPEG mode with same settings.

    720p HD mode (at 1920x720)
    image

    480p VGA mode (at 1920x720)
    image
    Screen shot 2011-05-29 at 23.16.26.png
    279 x 223 - 83K
    Screen shot 2011-05-29 at 23.16.46.png
    274 x 227 - 89K
  • YES!!! YES!!! You MUST USE FULL BATTERY. I saved it as GH1__133, version 10 and I added the 100 max patch, iirc.

    Put the full bat in, put the card in, turned it on and hit play and it said "please wait" instead of "no picture", then asked me to update, yes or no and of course I clicked yes....then the progress bar started. Took a little over a minute give or take.

    Now I can't find my data cable, of course the frustrations never end. :P Once again, Vitaliy is the man!!
  • Thank you very much Vitaly, I was late buying my GH1 (Ver 1.34)and got what I thought was an unhackeable one until now, it is now hacked and working using Ipowels safe settings.

    Will send a small contribution by way of thanks.
  • Beautiful. 23.976 frame rate at 1920x1080. I applied Blackout-Powell Native 24p setting. Gawd... I so wanted to try that setting. Thanks Vitaliy!!!

    Let met put 20.7 pancake and see if I can break it at highly detailed scene.
  • wonderful, my Aug 2010 GH1 (manufactured July 2010) is now on top !
  • i need help when i hit the play button it just says picture every time
  • Thank you for getting this up sooner than you had said Vitaliy, cheers!
  • A Japanese maple tree w/ lots of leaves. I forgot to trim it...

    It lasted 30 secs and failed to write. During recording, aliasing all over the LCD screen because the pancake is so sharp.

    Actually that's not bad. 30 secs is fairly long clip for me. Anything last 15 secs would do it. I used Sandisk Extreme III Class 10 16GB from Amazon.
  • so i got it working now do i use the same card or buy a new one
  • I just made a new topic with beginner's instructions on how to hack your unhackable gh1, that I moved from this area to there now.
  • Hacked again. Just wanted the stock 50mbs native 24p reliable settings so reformatted card. I named the bin file 134, one up from the 133, I originally did. Did version 11, one up from 10, topped up the battery just to be on the safe side and it worked.

  • @CRFilms

    You need to change increment only first time.
    If you use Prevent Version Compare you do not need to bother anymore.
    Same for file name. If PTool allow you to save file under such name it'll be ok (as it prevents you make wrong file name).
  • Nice Toronto...only thing I did different was:

    I did not add photos, I used a freshly reformated empty card, with just the bin file. I did 133 for the first file name and that worked and then I rehacked it and did 134 and version incriment 11.

    I did not hold the play button down 5 seconds, I only held it until the "please wait" screen came up, which seemed like it was instant.
  • @Vitaliy_Kiselev

    Thanks again....The FAQ needs to be updated a bit with all these little changes. For instance, FULL BATTERY needs to be highlighted. All these little things made it hard the first time.

    Once again, thanks Vitaliy for everything you've done.
  • do you use the card you hack to record footage or no
  • I used a cheap mini 2g sd card with adapter for the original hack because I could freshly format it since I had stuff on my 16gb card. I recorded a few clips with it then swapped the 16gb card and the card works.

    You only need the bin file on the card for the hack, once the firmware is updated you don't need it. But...some earlier hack users said they had multiple cards with muliple hacks loaded and just rehacked when they wanted to try different settings.
  • Reference guide for you peeps

  • Hi everyone, and massive thanks to Vitaliy for his continued efforts.

    I've done what feels like a lot of homework for this hack, but most of the instructions and other stuff (e.g. patches, recommended settings) seems to be for the GH1. I haven't found much for the GF1, which is the camera I want to patch.

    Anyone care to give a brief explanation-for-dummies what are the best hack settings etc for my (previously unhackable) GF1? I'm looking to gain manual film settings, and ideally a higher AVCHD bitrate (so long as it allows for in camera playback). Hopefully this is do-able?

    Thanks in advance!
  • @hearingdouble
    Make separate topic in hack category.
    Something like "Best GF1 hack settings discussion" :-)
  • Are there any (real, functional) differences between V1.34 and V1.32 firmware?

    What does the trick in downgrading?

    What is the date of the original V1.34 firmware in the service menu?
  • >are there any (real, functional) differences between V1.34 and V1.32 firmware

    No.
    May be few unmentioned fixes.
    Firmware had been introduced for one thing, really :-)

    >What does the trick in downgrading?

    Downgrading is downgrading, installing previous release of formware.

  • But downgrading did not work with previous version of PTool. So what did they do to prevent this that you have found out and fixed?

    Any clue what the unmentioned fixes fix?
This topic is closed.
← All Discussions