Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Please, support PV!
It allows to keep PV going, with more focus towards AI, but keeping be one of the few truly independent places.
PTool 3.56d topic
  • This topic is only about specific PTool version and is dedicated to talks only about new or fixed patches.

    You can report your results, best settings for this patches, etc.

    Download page:

    Remember that you need to check Version Increment patch(as you use older firmware) and use proper value for this patch (10 will do fine).
    It is also good idea to check Prevent Version Compare :-)
  • 98 Replies sorted by
  • Thanks Vitaliy. I suspect when you write "up to 1080p" for 480p mode that this is the limit?
  • @johnnym

    What do you mean?
    1080 always had been MJPEG limit (same with 720p mode).
  • Thank you Vitaliy :)

    OK, so anybody with a previously unhackable GH1/GF1 "got lucky" with this one?
  • What do you mean by proper value for this path? Version number or what? An example would be very helpful.
  • I have not been able to get lucky. In response to Vitaliy on the previous thread. I tried checking all three patches and changing the version number to 10, even 20. Still not workin' :(
  • @tommygdawg

    You are just doing something wrong.
    You are using GH1 with proper serial number (unhackable, I mean)?
    This patches had been tested not on one unhackable GH1 body, and all is working.
  • Technically I am not. My GH1 is an older one that WAS hackable. But then it broke, I had to send it in for repair. I put the factory firmware back when I did this. When the camera was returned to me they had installed the version 1.34 firmware and I have not been able to hack it since.
  • >When the camera was returned to me they had installed the version 1.34 firmware and I have not been able to hack it since.

    Are you sure about v1.34?
    As no one knows firmware that had been used in your case.
    May be they have completely different firmware for service centers, I do not know.
  • I checked the firmware version with the service mode of the GH1 and it did indeed say "1.34". This is maddening.
  • Hooray...I guess I'm one of the first one who got lucky with GF1. My Japanese sweetheart is talking to me in English now, thank you Vitaliy!!
  • >it did indeed say "1.34".

    In this case I think that most probably you are doing something wrong.
  • @JFK

    You had unhackable GH1, right? Serial?
  • I'm not sure what I could be doing wrong. Is there a certain naming convention I have to follow for the files or something? I've been trying GH1_132.bin (I think there's actually 2 underscores) and variations thereof, changing the version numbers.
  • Nope, I had a unhackable GF1 - FV0KD1.... Bought in January in Japan. I didn't expect it would ever talk to me in English, but it's great it does :)
  • @tommygdawg

    I suggest you to check your battery level. It won't update if it is not fully charged :-)
  • >Nope, I had a unhackable GF1

    Yeah. I mean that, just typed GH1 instead of GF1.
  • JFK what did you do? what did you save the bin as? Mine's not working either. Serial WE1BA.

    I've tried 135, 137, 142, 144, so far nothing. My battery isn't full so is that it? I'm charging it now.

    Vitaliy, when you said 10 did you mean save it as 140+? Does that mean 144 or 142?
  • @CRFilms

    Please, do not hurry. And charge your battery.
    You can leave original file name, just enter 10 in Version Increment.
  • Ok...thanks, didn't get version increment and that you had to put something in the ptool MENU not just rename the file. When you click "version increment" a menu appears at the bottom with green dot text, it says at the top "Enter Version Iincriment" in yellow/white dot letters and underneath it says "1". I didn't even see that the first time. This time I put 10.

    So...original file name as in firmware "GH1__132.bin"? Or since these are the unhackable, do we lable it 134?
  • And do you need to use a battery....can you use the DC power adapter?
  • My battery was full, formatted the card in camera, then put to the card reader and in Windows I added the file to the root (while leaving all other folders intact). As for the file - I checked all three patches and entered 10 in Version Increment. Saved it as GF1__123.bin (original filename was GF1__122.bin). Put it in the camera, pressed slideshow button and it worked :)

    btw...there was some mix up in my accounts, both JMF and JFK is me.
  • >can you use the DC power adapter

    Do not even try. As any problem with electricity and your body will be bricked.
  • But all GF1s are hackable, aren't they? You have a GF1 F or GH1?
  • >But all GF1s are hackable, aren't they?

    No. Plenty of unhackable GF1 on the market.
    Same for G2 :-)
  • No matter what I do I can not get it to work. My battery is fully charged. RAGE
This topic is closed.
← All Discussions