Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Please, support PV!
It allows to keep PV going, with more focus towards AI, but keeping be one of the few truly independent places.
Xiaomi Xiaoyi YI-M1 m43 camera, 4K video, $213 only now for kit
  • 303 Replies sorted by
  • @konjow

    As far as I see it is not sold as body only.

  • Even if you have to buy it with a lens, if you keep your eye out, you can find cheap deals. I picked one up with the 12-40mm lens as a lightning deal for $240... that's pretty great for a m43 camera with a (so-so) 4k video mode. I'm excited to get full manual control for video with it!

  • @eatstoomuchjam

    Did you tried this new firmware?

    Also does it have 4GB limit still?

    Also can you select bitrate for 4K?

  • @Vitaliy_Kisilev I just went to download the link to give it a shot (since the app and the Yi download site still say that 2.0-int is the current version), but the link seemed to be to a phishing site that was trying to look like facebook. I'm not having much luck finding an actual link to the preview f/w. If anybody has one, I'd be glad to download/try it.

  • Ah, I guess the domain maybe isn't a phishing domain, but the result of someone clicking on one of the files in a facebook group's "files" tab. I've found one or two other links to it pointing to the official Yi M1 facebook group so I sent a request to join it and I'll download it directly from there after I'm approved.

  • This is the FB link for the preview version of the 3.0 firmware

  • @samuelcabral When I clicked that link before, I got a page which wants me to sign in with my facebook credentials. I don't trust it. If that link is working for you, maybe you could upload the firmware to dropbox or something similar?

  • @eatstoomuchjam

    For me work fine, download just starts.

  • @eatstoomuchjam

    I sent you wetransfer link, see email, I think you can share it here also.

  • @Vitaliy_Kisilev Great, thanks for grabbing it!

    wetransfer link

    I have the new firmware installed - instead of 3.0.0-INT, the firmware version shown on the firmware settings page is 2.5.5-INT. I see no options for adjusting bitrate, sadly. The PASM modes for video work, though. The firmware zip file included a powerpoint presentation describing how to use it - the trick is to hold down the video start/stop button for 2 seconds.

    Observations so far:

    • My video didn't cut out at 4GB, it cut out at 1GB. I'm looking to see if I missed an option to make it be more than that. Thanks to the low bitrate, 1GB is still about 7 1/2 minutes, at least.
    • Crop is still present in 4k (probably a hardware thing that firmware can't fix, but I was hopeful)
    • Liveview still doesn't seem to have an option to reflect actual exposure (or maybe I'm just being dumb and missing it)
    • Touch autofocus in video mode works OK - about as well as autofocus works anywhere else (pretty slow)
    • The current version of the smartphone app fails to turn on wifi when connecting to the new firmware
  • Oh, and if there is an option to adjust the size and there is an option to go beyond 4GB, it would have to be done by spanning. The camera formats the card fat32 and when I tried formatting it exfat in my computer, when I put it back in the camera, it said it couldn't recognize it and prompted me to format the card.

  • @eatstoomuchjam

    Can you please test spanning feature? Like try to record 1-2 hours.

    And for camera guys it is time to start work with exfat, really.

  • @Vitaliy_Kisilev I don't see a spanning feature. Sorry if that was unclear. I was only saying that they'd have to do it by spanning since it's FAT32. I couldn't even find an option to go to the full 4GB file size. Mine cut out at almost exactly 1GB. I'll try with a faster card just to be sure, but the UHS-1 card I was using should have been more than able to handle 60 megabits/second.

  • Confirmed - it cut off again at 7:29 with a Sandisk Extreme Pro UHS-3.

  • @eatstoomuchjam

    Very strange.

    Previously was 4GB?

  • @Vitaliy_Kisilev Some reviews say 4GB, but they also mention a 7 1/2 minute recording cutoff so I'm not sure that any of them actually looked at the file size and that they just assumed it was due to a filesystem limit.

  • @eatstoomuchjam

    Do you know any developers contacts?

    I see feedback XLS form inside, where to send it all?

  • @Vitaliy_Kisilev I definitely don't have any contacts. I just checked again - when it hit 1GB, it was a black frame with the lens cap on. This time, I took it off and the file is 4GB. I was also wrong about the bitrate - I was thinking 60 megabits and Windows shows it as more like 75 megabits/second.

    905 x 1281 - 65K
    795 x 908 - 49K
  • @eatstoomuchjam

    So, actually they stop not upon size, but upon time.

    But time is selected by developer to not allow crossing 4GB.

    P.S. I think it can be good idea to ask them on facebook about where to send firmware feedback form.

  • As soon as they approve my request to join their group, I will ask!

  • Just send your e-mails to, guys.

  • @samuelcabral

    Thanks, wrote them email.

    Will try few other approaches. Including talks on exhibitions.

  • You're welcome! I still didn't lose my hope with this camera. It has potential, but they need to listen to more professionals to make it a competitive product.

  • @samuelcabral

    What exactly you want them to do?

    For now basic thing is make spanning working or get exFAT working.