Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
gh1 No Valid Picture to Display Update problem
  • Hi I have been searching around for an answer to this issue and although i found a lot of people that have the same problems no one seems to have an answer. I have no idea why it has started doing this and I really need to change the hack that is presently on the camera. Any ideas of how to get it back to recognizing the firmware updates? I tried: -Updating Panasonic official firmware. -Version Increment ticked and unticked -Prevent Version Compare ticked and unticked. -Renaming Firmware to a variety of names going all the way up up 150 (camera says its on 1.3).

  • 9 Replies sorted by
  • Did you format the card so there are no files on it and then make sure that the .bin you are copying is the only one?

  • Thank you so much for the reply.. yeah I tried this I formatted in the camera and on pc... its really strange I have no idea what I have done....

  • Tried version increment on 2?

  • I am confused by what all this increment stuff is. Does the increment have to be higher than the installed firmware on the camera? Or higher than the firmware I am using to patch in ptool? I dont get why this isnt working. Also it used to say version o.o and not says 1.3 in the camera since the last patch.

  • Its not like I have never got it to work, its already got a hack on it but its not the right one..

  • You can leave the filename of the firmware just as it is, no need to change anything here. Version increment is a internal marker or tag (dunno how to call it) that sends a signal to the cam that this is a new firmware. You dont need to increment on each flash, if a number worked it usually will work again. I had the case with second GH2 which would not flash with version increment 1.

  • ARGH! Mate that made more sense to me! Thanks! :-))))

    I will try again and now I understand its the "internal" label I should be able to work this out..

  • I am sure you have sorted this as now I get the "battery must be fully recharged for firmware update", so at least it is recognising that there IS a firmware update! I think it will work now I am just charging my battery ;-). SO now if I use the "Prevent version compare" choice it will no longer need the increments as the firmware inside the camera will not check the version? Cheers again.

  • dude absolute ledge it was that simple and it makes much more sense now... Thanks a lot..