Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
Patched firmware not displaying new filename after install
  • Hello,

    I'm new to this. I just picked up my new GH2 and after first updating the Panasonic GH2 firmware from V1.0 to V1.1 and doing some testing I then attempted to install the Sanity 5 firmware patch. I followed the PTools instructions. I downloaded Ptools and the GH2__v11.bin from Panasonic and opened the bin file in Ptools. Then I applied the Sanity 5 patch and saved the patched firmware as "GH2__v12.bin". After installing it on my GH2 I checked the firmware version and it still shows it to be Version 1.1 not Version 1.2.

    How can I determine if I have actually patched the firmware? I would assume it hasn't worked because I don't see any change in the firmware version and can't tell from the menu settings if anything else is different.

    I seem to be missing something here.

    Thanks pundit.

  • 5 Replies sorted by
  • @pundit I am new to it, too, but my understanding is that your patch is working. Because the patch is based on the original firmware released by Panasonic your camera will only show the version number of the current original firmware. Check your recording times, you should be able to fit less footage per card (depending on the actual patch it will change more or less dramatically), this is one way of telling if the patch is working. Of course image quality, too.

  • Thanks for the quick reply. I looked through many threads but couldn't see anything about the firmware version remaining unchanged after it was patched. It kinda threw me because I didn't think it had worked. It would be nice if some kind of visual confirmation could be included after the patched firmware was applied. I guess it's not an issue for the more experienced guys but for a first timer you find yourself flying a bit blind. (I'm a photographer just getting into videography.) Now I need to see what kind of bitrates I'm getting - Cheers

  • I just shot a clip of 2min:30sec and it was 408mb is size and looking at the bit rate I would say the Sanity 5 patch worked as it reaches a max of 45.1 mbps. I shot some trees and rocky ground while panning quite a lot so I could see how high the bitrate would go and it went way past the factory max of 24mbps.

    Bit rate mode: Variable Bit rate: 21.7 Mbps Maximum bit rate: 45.1 Mbps

    Cheers

  • your filename is just for the camera to recognize the update. the displayed firmware version always is that of the base firmware.

  • Have a romp around this forum. There are some good analysis tools out there which can help you look at what's happening during your files. Elecard Streameye is one such. You may find bitrates varying (depending on which patch you have loaded) and also varying according to shutter speed (low speeds can blur the images so give the camera less data to compress) and on overall motion and detail (for example, the "sharp" lenses may give the camera more data). If you enjoy that sort of thing of course! Or just enjoy your new camera!