Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Please, support PV!
It allows to keep PV going, with more focus towards AI, but keeping be one of the few truly independent places.
GH_2 PTools problem
  • I am new to this whole process. I have modded only on PC's, never camera's. I have downloaded PTools as prompted. I have also tried several different settings redshift_v4, moon, apocolypse now, just to see if I could get to work. ptools doesn't recognize any of the files for uploading. The only one it does recognize is the -V103 which is supposed to emulate the original firmware. Please help! I think the Sanity 5 patch I bought the GH2 with is corrupted, because In video mode it's stuck in automatic. I can't change the ISO, or anything. Very strange. I find the GH2's firmware rather shoddy to begin with. If there are any really good firmware updates that you would recommend after the ptools issue is fixed, I would very much appreciate that as well.


  • 6 Replies sorted by
  • The GH2's firmware is just fine. Do Menu, Setup, Reset just to make sure your camera is in a good state. Set the top dial to Creative Movie Mode (the projector icon), and you should be able to set the ISO. If you can't get that far, there's an operator error. Read the manual. Read the FAQs linked at the top of this page, particularly the PTool FAQ and the GH2 Usage FAQ. There is no other firmware except the official Panasonic firmware and any modified firmware image you make using PTool.

  • Wrong firmware this is. Just get firmware v1.11 downloaded from the Panasonic site. Use that and it'll work.

  • I am hoping it is operator error, but there are a couple issues that seem to call for a fresh install. I have shoot without lens on, but says it's off. It defaults in teleconversion mode, where it allows you to change setting, but then upon switching out of teleconversion, it reverts back to auto mode.

  • I don't think it's even possible to flash the wrong firmware image or to flash a corrupted firmware image. The camera would reject it. I haven't heard of a case where a camera was misbehaving and flashing again fixed it. But you're certainly welcome to try. Did you reset the camera like I said?

  • @tokyo187 "I thought I heard another splash in the deep end as I got dragged out, and was resusitated by some kind people on this site".. I have empathy for you. After reseting your camera as per @balazer, downdload the latest firmware as per @driftwood, after refering to handbook for instructions on body and lens firmware status, possibly update both if needed via Panasonic. Chesk FAQ for best SD card to use with various patches... Me 95/64 sandisk, no looking back. Refer to something Like OSG films. great tutorial. Cheers.

  • Thanks everyone. I am now trying to figure out how to get adobe to accept and correctly process the media from the slipstream. I am having problems with the footage not being able to stay caught up. many hiccups and audio not working, etc. . . I will create a new post, but reply if you have any ideas

    Thanks again everyone

Start New Topic

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Sign In Register as New User

Tags in Topic

Top Posters