Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Retrieving Data from SD Card with bad sectors
  • Hey everyone, today I had a monumental technical hiccup. I searched the forums here for similar stories, but mine seems to be a bit unique, so I thought I'd share it.

    I spent about 4 hours this morning doing some foley and voice over work on location, I tested the audio after each take and it all played back just fine and sounded great (trusty H4n). When I got back to the editing suite and popped the card in, it took about 30 seconds for the card to pop up, which was my first red flag. Then I opened it up and it looked empty at first, then I literally watched the H4n file structure slowly appear before my eyes one folder at a time, second red flag. I attempted to copy the data over to my worktable drive and it started the visual indicators of a transfer process but never began the actual transfer. A left the work station alone for about 45 minutes and came back to a spinning wheel of death and discovered that finder had crashed without transferring a single bit or byte of the data. I tried to relaunch the crashed finder but it didn't reopen, I was left staring at my desktop backgrounds and nothing more and had to manually reboot the machine. This is where it got really fun. Now the machine would not boot up with the SD card inserted, it would just hang on the boot screen. I tried a few times, then powered down and removed the SD card and the machine started up fine. Then I put the SD card back in and the drive pops up, but as soon as I go to open it, finder crashes again. I can't even get far enough to see inside the folder anymore. Ok, so it's clearly a corrupt SD card and I'm ready to introduce it to it's new home: the garbage can, but first I need to attempt to retrieve any data I can to save me from asking my client to take another 4 hours to re-record all the audio (which, as you all probably know, is never as good the second time around). Not the end of the world if it comes to that, but I'd really rather not have to go that route, if it is at all possible to avoid. I tried the same card in a different card reader on a different work station and got basically the same results - unable to access the drive or data. So I started some research into data recovery software options and decided to give Stellar Pheonix Mac Data Recovery a try. Even the software couldn't see the drive in it's more common data backup and retrieval services, but I discovered could see a 'Generic 16GB SD' drive under the 'Image Creation' option, which it states is for exceptionally problematic corruptions. Basically it aims to create a mountable .DMG image containing every sector on the drive (including ones not in use). So I went for it. The software begins the sector processing on block 0, where it sits for about an hour. I was just about to give up and shut it down when all of a sudden it progresses, identifying block 0 as being fine, but block 1 as a bad block and continuing on, the next 30 blocks (700000 sectors) go by like a breeze, all fine, but then it gets stuck again around block 30. I'm going to leave it over night and sleep with my fingers crossed, but if anyone else has any insight or experience with a similar issue, please share your experience. I will update this thread tomorrow with results of the attempted data recovery, good or bad.

  • 4 Replies sorted by
  • @Vitaliy_Kiselev Yes, I saw that post, but I thought my scenario was different as I can't access the data or disk at all. I can't even access the card, not on the original device, nothing, which appears to be a different scenario entirely from that topic (and the others on corrupt files I found on PV) so I thought it was enough to merit it's own topic. Sorry about posting in gen cat, maybe we need a 'troubleshooting' category.

    UPDATE: so the damndest thing just happened. The block scan completed and a .dmg image was successfully created, but upon mounting, the .dmg is also corrupted and not recognized as a drive by OSX (or any recovery software). Then magically my H4N_SD drive pops up on my devices again and I am able to access it and copy the files no problem. Uh.. what? Not that I'm complaining here, I just wish I knew what happened it so I could share it in case someone else has a similar issue in the future... but I am at a loss for words. Which I guess I'd prefer to a loss of data.

    Now I will take a hammer to this SD card and try sweep up all the hair I just pulled out.

  • May be something with USB cable?

  • Card showed at least 2 bad blocks (plus I tried it with different computers and different card readers). I wonder if one of the bad blocks (I'm guess in block 1, which was corrupted) might have held some critical controller data for the card, and when I created the image clone of the SD with the data recovery software, it maybe repaired it in order to access the card (if SD card controller data is universal, this isn't too far fetched). Admittedly, I'm grasping at straws here.