Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Please, support PV!
It allows to keep PV going, with more focus towards AI, but keeping be one of the few truly independent places.
QUESTION - GH2 AVCHD Timecode Corruption on Import into FCPX
  • So I have had this issue for a couple weeks now, and I don't know where else to turn.

    I hacked my GH2 a few months ago and things have been pretty lovely so far. A couple weeks ago, however, as I was importing some AVCHD files from my SD card (64GB SanDisk Extreme) into Final Cut Pro X and some of them gave me this error upon import:

    "Import Failed: The following clip encountered an error during import and is still referencing media on the camera: Clip Name: 2012-12-01 19:21:00 Event: X Original Name: Clip #X Volume: NO NAME"

    After looking around, I noticed that the files that presented this issue had a strange timecode. Instead of displaying a normal start time of "00:00:00:00" they started with "23:27:41:06". Only some files are like this, and as far as I can tell it only happens to clips that used lenses that have been adapted to the camera (non-4/3 Panasonic lenses).. Other than that I don't know what's going on.

    Has anyone else had this issue? Is there anything I can do to fix it?


  • 22 Replies sorted by
  • Here's a picture.

    Screen Shot 2012-12-01 at 10.28.31 PM.png
    1018 x 269 - 57K
  • I got the same problem. I used a hacked GH2, 64GB SanDisk SDXC1 Extreme Pro SD card, and FCPX. Only one file showed "import failure", same as described in the original post. But I don't know why and how.

  • I got same problem too I suggest to import and covert AVCHD files with ClipWrap application ("Rewrap dont'alter video samples" as setting )!

  • Hi, I'm using Intravenus 2 and two times out of the last maybe 10 imports, I've had import errors in FCPX. I'm using Panasonic Leica DG 25mm, 1080 24P on a Sandisk 64GB 45MB/s card.

    Both times, the clips were about 2 min long and the FCPX import window showed the clip NOT starting at 0:0:0:0 on the card. The most recent occurrence showed starting at 23:27:41:06 and ending at 23:29:41:17. Whenever import works as normal, the starting point of the first clip is 0:0:0:0

    The FCPX error message says "The following clip encountered an error during import and is still referening media on the camera"

    I tried both importing from the sd card and copying sd card contents to hdd, then importing from hdd, and I get the same errors both ways.

    I'm able to drag the clip to my FCPX Timeline when it fails and resorts to "referencing media on the camera," but I can't share the file (export) because "This item cannot be shared while it is still referencing media on the camera."

    @mclarenf1 seemed to have a similar issue and fixed it by importing from hdd after @driftwood suggested it, but that didn't fix it for me.

    I used Flowmotion 2 for a while and never had any issues like this, but I want to try out intra, so hopefully the clip is salvageable.

    Any suggestions? Thanks

  • @TGDude Did you copy the entire private folder over containing the mts file?

  • @driftwood yes I copied everything from the SD card over and the clip was recognized by fcpx's import screen, but the error still occurred afte r selecting the clip and clicking the import button

  • @TGDude I've seen this problem many times, and found ClipWrap does the job nicely, as @valpopando recommended.

  • Could be a corrupt index file. Just clipwrap it as people above state for instant fix. If not, maybe an edit on the index file with an editor could rescue the timecode.

  • Thanks for the advice. The ClipWrap demo only lets you wrap the first minute of footage. My clip is 2 minutes. It costs $50 for the full version of ClipWrap. I'm wondering if it will be worth $50 just to import Intravenus 2 footage the 10-20% of the time that the clips don't import properly or if I should just go back to Flowmotion or try another hack. All I want it a very high quality hack for narrative short films. Hmmm...

  • Ok, I found a free solution.

    Media Converter:

    Combined with this preset...

    "Re-wrap AVCHD for Quicktime - uncompressed Audio":

    It claims to have no quality loss.
    I successfully re-wrapped my 2 minute, 1.3GB file within 10 seconds.

    If anybody has any thoughts or experience with this ( @htinla ), I'd like to hear. Especially if you took the time to pixel peep and verify that there is no quality loss.

  • I have the same problem importing footage shot using Moon Trial 3. A percentage of the clips have their timecode starting at 23:27:41:06 instead of 0:0:0:0 and they cannot be imported in FCPX directly. I am using Media Converter to rewrap the files but it's time consuming to do this every time.

    @driftwood I suppose forcing the starting timecode to be 0:0:0:0 is not in your power. Is it something you can deal with parameters in PTool? Or do you have an idea in which files in the AVCHD structure it is encoded? The .CPl or the playlists?

  • @phouba TGDude Try to establish when the timecode reset/change happens. Do you film a clip, switch off, turn on again and film other clips and is this where the code is changing? Or is the pattern irregular?

    @All I do recommend Clipwrap rewrapping - its worth the cost for the trouble of sorting out problems like the above if not only to get fcpx to import files nicely.

  • I filmed a lot of little clips yesterday and it seems that there's no regular pattern i can find.

  • I have the same problem running Moon 5. I copied the card's directory structure to disk - no change. The faulty timecode shows up on six clips out of 22, 2-5, 10, and 20. Clip 2 is 1080P/24 EX Tele. Clips 3 and 4 are Variable Movie Mode 80%. Clip 4 is EX Tele as well. Clip 5 is 160%. Clip 10 is 200% EX Tele. Clip 20 is 720P/60. The remaining clips are a mixture of 1080P/24 and 720P/60, and they all import with no problem. When I attempt to relink, the directory structure is not available. Reimporting doesn't help. Also, now when I open FCPX, I get a message "The file Final Cut Events couldn't be opened."

  • Theyre fine with Clipwrap rewrap. Its worth the purchase I keep stressing. However, Ill try and get to the bottom of this cus Ive seen this on stock HBR recordings too now. Can anyone confirm if they switched off camera before shooting another clip and then there was a timecode problem or did they happen with a continuous on - changing rec mode - hit record. Lets try and figure this out.

  • In my series, clips 2-5 were recorded at different modes without power cycling the camera. Somewhere around clip 10 (300%), I was unable to set shutter speed slower than 1/25, so I tried power cycling the camera, which worked. It looks as if changing mode may be the issue. I'll shoot a test today to check that hypothesis.
    BTW, I don't know if this deserves its own topic, but I was unable to export a frame from MPEG Streamclip on clips without the timecode problem. The error was "Unable to read frame size." @Driftwood, is there any reason to prefer Clipwrap over 5D2RGB or vice versa?

  • I tried again this afternoon. 7 Clips. 1st - HBR, 2nd - 24P, no problem. 3rd clip was Variable 80% - this clip exhibits the problem. Clips 4-6 - 160%, 200%, 300%, no problem. Clip 7 was back to 24P - this clip has the problem. So, it appears that the problem arises when switching from 24P to Variable Movie Mode and back.

  • I just know from all my rewraps using clipwrap writes the timecode starts to 00:00:00:00 - another reason why I recommend it.

  • This keeps coming up in other forums threads. I have had the same problem with FCP import failing. As per suggestion here from @driftwood - I have gone and purchased clipwrap and the issue is solved. I can now archive my original footage as .mov clips without transcoding and easily reimport to FCP or other software as needed. Since FCPX doesn't ingest .mts clips directly without the entire folder structure - it's a great option to simplify workflow.

  • I have been using Flowmotion since getting my GH2 back in December and never had this problem. The other day I thought I would give Moon trail 5 a try, guess what, I started getting this issue with every batch of clips I recorded. Went back to Flowmotion and all is good again.

  • Yes, this is the same for me. No problem with Flowmotion, but the problem occurs regularly with Moon T3 (once every 5 or 10 clips approximatively without clear motives : I shoot almost always in 24p, 24H or 24L, several different lenses). Maybe this happens when card is written too fast (although i'm using SanDisk 64Gb 95MB/s) or only for Intra settings? I also tried DREWnet T8 but clips were too often corrupted (once in a while, clips were full of macro blocking, so unusable), maybe this was related to wide angle lenses (using SLR Magic 12mm or Samyang 7.5mm). I keep using Moon T3 until a better hack comes because i can use Media Converter to rewrap the clips (Clipwrap also works but i only have the demo version working for clips under 1 minute).

  • FYI I've had the same issue for several years (since I hacked the GH2) and have dipped in an out of forums from time to time to try and final solution that actually fixes the issue without having to do a work around. BTW the issue only seems to happen when using FCPX. I have an old version of Final Cut Express on my hard drive and even though in FCPX on average I can only import 20% of my clips, I've found by using Log & Transfer to import them in Final Cut Express is faultless. Since using this method I haven't had a single failure. Would still like to be able to import directly into Final Cut Pro X though.. without the messing around.