Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
GH1 720p Video and Audio settings
  • Hello all, this is my first post here.

    I just purchased a GH1 which I intend to use with a bunch of old Nikon lenses.

    Having older computers I've always had trouble with full HD anything so for the time being I'm not interested in 1080anything.

    I would like to create the best possible 720p60 files recorded onto Class 10 cards with absolute reliability.

    My intended use case is recording for longer periods of time in a variety of documentary / journalism type environments. Therefor reliability is far more important than quality. That being said I'd still like to increase the quality of the 720p60 video if possible.

    Would anyone be willing to share their 720p60 settings with me?

  • 25 Replies sorted by
  • You might like the Reliable In Camera Playback patch. I have tried it and it gives great results.
  • I've tried the Reliable in Camera Playback patch (v2) as well as a less 'aggressive' patch.

    Apparently my computer does not decode higher bitrate 720p60 files well either. (urghh)

    So before I go upgrading my machine (or machines plural!) let me ask the following:

    Should my machine be having such a hard time? Is it a Dell Latitude D820 - Intel C2D @ 2.0 GHz - Geforce Go 7400 - 7200RPM HDD @ SATA1 - Win7 @ 32bit with a 1920 x 1200 display.

    I don't want the added expense of upgrading my machine but will begrudgingly accept it if I have to.

    Any and all input greatly appreciated.
  • @Davide_NYC: How much RAM do you have? What program are you using to edit? What programs are memory resident in RAM?
  • I have 4GB of DDR2 RAM (~3.5GB accessible on 32bit Windows)

    I'm just trying to decode smoothly at the moment.
    I've tried Media Player Classic Home Cinema, VLC, MPlayer to playback.
    I turned on the hardware decoder option in VLC.

    I can try to edit in Sony Vegas Studio HD Platinum 10 which is what I would be using to edit (hopefully).
  • @Davide_NYC

    It might be that your GPU (video card) is not providing you with the necessary horsepower to decode MTS files (w/128MB of VRAM). Granted the chipset is 5 1/2 years old which isn't necessarily a good thing, but should be able to decode the codec. Otherwise the memory specs and OS seem fine.

    http://www.notebookcheck.net/NVIDIA-GeForce-Go-7400.2143.0.html

    Anyways if this is the case I would look into what type of video card your machine can handle and upgrade to a better dedicated GPU (an AGP video card w/at least a gig of VRAM should suffice) or use a desktop better suited for this purpose.
  • It's a laptop, thus not upgradeable... it seems likely that I'll need to upgrade. (sigh)
  • If your computer can't watch those files, you'll have to transcode them into an easier to view format. I turned my high quality files into the main concept 720p settings. It's one of the vegas presets. Those files are real easy to edit and preview in realtime even on slow systems.
  • Try splash media player, it seems to play most formats on slower machines.
  • @Davide_NYC: Do you have hardware acceleration enabled? If not, you should enable it.
    1. Choose Start > Control Panel.
    2. Click Apperance/Personalization and then click Display, then Change Display Settings.
    3. Click Advanced Settings.
    4. Click on the Troubleshooting tab, then Change Settings.
    5. Move the Hardware Acceleration slider to the max.
    6. Click Apply and then click OK to accept the new setting and close the dialog box.
    7. Click OK to close the Display Properties dialog box.
    8. You may need to restart Windows.

    You should have enough CPU power and free RAM to watch HD video, so it seems to me that your video card RAM may be an issue, you may not have hardware acceleration enabled, or you have another program (like an anti-virus program) that takes all your CPU power when you click on the file.
  • I am not very tech savy but with my older Dell PC (6 years old) I was able to playback files with the Media Player Classic only. Even now, with a new Dell, MPC gives the best results for playback. Definitely follow Mr. Anthony's advice above. BTW? PowerDirector is a great and cheap program for editing HD video on a PC.
  • @Everyone: Thank you for trying to help me! I really do appreciate it.

    @CRFilms: I can't afford the transcoding step in my workflow. I just tried to render the file as HDV uncompressed 1280x720 60fps w 48k/16bit PCM audio in an AVI and it's huge (expected) but also took way too long to transcode.

    @MrAnthony: When I click on the troubleshooting tab the Change Settings button is greyed out. I'm using Nvidia driver version 275.27 (not WHQL) which sees the GPU as a Geforce Go 7400 even though the card was sold as a NVS120M (Quadro). This might be the problem.

  • If you want 720p and your system can't do regular mp4 or mov, transcoding into Mpeg2 720p 30p is the only way free way. The Mpeg2 is faster to transcode than that avi setting, and it edits fast. You either spend time or money...time to transcode or money to upgrade.

    These settings are the settings you want, not avi. It's one of the vegas presets. It edits FAST, and if you don't render effects or color settings, it renders without re-transcoding.
    720x30p.JPG
    439 x 139 - 22K
  • good topic and good feedback so far!

    Is there a 24p patch for "Reliable In-Camera Playback"?
  • @CRFilms: I took your advice but rather than keeping the 30 progressive frames per second I created an HDV 720-60p HQ present that will hopefully preserve as much of the original file information as possible. Still getting a lot of "smudge" during panning that I don't like, but for what I'll be doing there won't be too much panning. I suspect there is not much that can be done about the smudging.

    I still intend to upgrade my machines, as trans-coding is a pain, just not immediately.

    Thanks again.
  • @Davide_NYC I have vegas platinum 9, it doesn't let me change the HDV presets. I used that preset because it was the easiest and it worked with the re-renderless transcode if all you do is edit. You might try the HDV 1080x60i settings. That also edits fast and you could do the final render in 720p progressive.
  • So Davide, why didn't you try the free Splash Media Player i recommended you, i guarantee it will play on your machine. http://mirillis.com/en/products/splash.html


    R
  • @Rambo: Wow! That player is extremely efficient! Loving it!
  • @Davide_NYC: It sounds like the big issue is that you don't have hardware acceleration enabled, so the heavy lifting is being done by your CPU instead of the graphics CPU (GPU). This probably accounts for your issues, so a software-based player that isn't CPU intensive probably works as you've noticed. Longer-term with this machine, you might consider finding a driver that will enable hardware acceleration on the video card.
  • @MrAnthony: I'm not sure how to confirm that the hardware acceleration is enabled/disabled. Please take a look at the screenshot I've attached. Is the "Video Engine Load" (currently at 0) from GPU-Z the parameter that I need to be looking at? Once I learn how to confirm/deny that Video Hardware Acceleration is working I can experiment with some more confidence. In the mean time I'm just under 100% load for but CPU and GPU load.
    CPU-GPU-Performance.jpg
    1307 x 771 - 109K
  • @Davide_NYC: Wow! That player is extremely efficient! Loving it!

    If you click the "i" icon it will give you the frame size,FPS and data rate on the fly. Great for monitoring the clips bitrate.
  • @Davide_NYC: Yes, video engine load should show a number if you're using the chips on the video card to do hardware decoding. However, if you're using a software based player, it probably by-passes the video card decoding and goes to the computer CPU to do on-the-fly decoding. You could try with your older software that stuttered and see if the video load engine comes to life; my guess (and admittedly, it's just a guess) is that you don't have hardware acceleration enabled, and the CPU peaks out periodically, causing your video stuttering. Or it's possible that the notebook version of your graphics card doesn't come with hardware decoding (unlike a desktop model).
  • I suspect I just need to upgrade the hardware (bummer) if I want accelerated H264.
    http://en.wikipedia.org/wiki/Nvidia_PureVideo#Table_of_PureVideo_.28HD.29_GPUs

    Board Name: GeForce 7 series
    Core Type: G7x
    PureVideo HD: VP1
    VDPAU feature set: Not Supported

  • You're right! All the online material says that H.264 acceleration was supported, but clearly, it is not, until later generations of PureVideo. I notice that the next generation supports high def formats.
  • I purchased a Dell Precision M4400 which is not the speediest thing out there, but at least I can do some hardware H264 decoding now! (never cheap!)

    Now that I can play back these file reliably I would like to go back to my original question: What settings do you all use to get the best possible moving images in 720p resolution?

    What bitrate? What GOP length?

    I like how "tight" everything looks when using MJPEG so I'm asking about low GOP settings under AVCHD.

    Thanks!
  • For what it's worth, I just got back from some shooting and settled on the following settings:

    720p59,94fps->29,97fps=Checked
    Video Bitrate FHD/SH=32000000
    Overall Bitrate=34000000

    I liked the way it looked and my editing software handles it native without having to transcode or do any other heavy lifting.

    I just wish I could switch between 60fps and 30fps in camera.