Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
Please, support PV Japanese team!
It is same real forum members as you who will be talking to all camera corporations top managers at CP++.
PTool 3.60D: Encoder Setting 1 controls B-Frames
  • I have isolated Encoder Setting 1 for 720p and I can unequivocally say that it determines whether the codec uses B frames or not. If you change nothing else and use Encoder Setting 1 = 3 it will use B-Frames. If you use 2 it will not use B-Frames. It also increases the bit rate up to 22 mb/sec to almost 24 mb/sec. Using B-Frames with 720p improves it tremendously. However, stability is an issue. If you record a 1080p @ 24 FPS video first and then record 720p @ 60 FPS stability returns.

    I have attached the testing I have done so far and the best stream parser results I have seen. VLC indicates that this is still true 720p @ 60 FPS with B-Frames.

    Feel free to use this information as you see fit. I don't need credit. It is not like I am planning on getting a patent on the settings or anything.
    GH2 Ptool.xlsx
    14K
    720p Ideal Settings.jpg
    1600 x 900 - 360K
    GH2 Ptool.xlsx
    14K
    setb.zip
    461B
  • 26 Replies sorted by
  • Here are some Stream Parser images that show 1080i and 1080p @ 24 FPS without B frames. Not neccessarily something you would want to do. However, the only setting changed for these two resolutions was the single encoder 1 setting. It went from 3 to 2.
    1080i Without B frames.jpg
    1600 x 900 - 356K
    1080p without B frames.jpg
    1600 x 900 - 347K
    1080i Without B frames.jpg
    1600 x 900 - 356K
  • I've come to the same conclusion, I did the reverse of changing the Encoder Setting 1 for 1080i/p to 2 and the resulting files were missing B Frames. 1080i60 requires Encoder Setting 4=16 for it to encode B Frames, a value of 8 results in choppy images
  • Encoder = 17(Which is the default) will give you B-frames for 1080i. Encoder 1 setting is the only one that matters right now.
  • Excellent @mpgxsvcd

    I'd like to see some tests with B frames on / off in the same mode, with different bitrates. Turning b-frames off might free up CPU time for higher bitrates, although it might be better to compromise bitrate and keep b-frames turned on. We need to find out which of these approaches produces the best image...
  • But Encoder Setting 1 is the same shared value in ptool. It's is "Encoder setting 1 1080i/p" which of course already equals 3.

    What do you change to get B-frames on 1080i60?
  • You get B-Frames with 1080i by default with hacked firmware. If you tick the 1080i/1080p Encoder 1 check box and don't modify the value you will get B-Frames in both resolutions.
  • Upping buffer for 720p will result in sub standard video. Right now Buffer = 18 is the only one that is acceptable.
  • oh really, that I never tried :)

    Edit wait actually I did. I don't have "Encoder setting 1 1080i/p" checked on my settings. Very strange.

    I think I'll clear all my settings and start over with a clean plate
  • @Dazza

    I had to start fresh again as well. It looks like the only thing you need to change right now is the Encoder 1 setting for 720p. Just set that to 3 and you will have excellent 720p with B frames at 22-23 mb/sec. Everything else will be the same.
  • Here are the ideal settings for 720p. This file does not affect 1080i or 1080p.
    setb.zip
    464B
    GH2 Ptool.xlsx
    15K
    Best 720p Ever.jpg
    1600 x 900 - 345K
  • The excel spreadsheet had a mistake on the last entry. The GOP was actually 15. Here is the latest version.
    GH2 Ptool.xlsx
    15K
  • @mpgxsvcd
    Next time use proper category and tags, please.
  • @mpgxsvcd

    you forgot to set the 720p SH to 24mbit in your posted settingsB.
    With your settings you could only get a max bitrate of 18mb/s.
  • Over good idea is to use Overall bitrate patch and not forget Video buffer.
  • @mpgxsvcd - cool, thanks (and of course most of all to you, Vitaliy)! Suppose green is the setting with the best results so far? I'll adapt the gop lenght to PAL and try it out in a couple of hours.
  • From the extensive testing I did last night. The overall bit rate settings have no benefit on the video. Those settings actually have a negative impact. They cause the codec to ramp up really high at first and then over compensate and produce a pumping affect in the video. You can see it in the attached stream parser file.

    You are much better off to adjust the Codec Setting 1 to enable B frames and leave everything else unchanged. That will automatically increase the overall bit rate to 24 mb/sec or more depending on whether you have decreased your GOP or not. Decreasing the GOP decreasing stability drastically though.

    The 720p setting is not anywhere near stable yet. It will fail everytime if your first action is to record 720p video. If you record 1080p @ 24 FPS first it will be very stable with a GOP of 30 though. A GOP of 15 is fairly stable as well if you record the 1080p first.
    720p Pumping.jpg
    1280 x 1024 - 324K
  • I am having trouble playing the 720p files with B-frames in VLC. It freezes after a second or two. However, the files play just fine in Windows Media Player. I think the GH13 had a similar problem that I had fixed by installing something. Does anyone know how to fix this issue with VLC?
  • Here is some nice GOP = 30 720p. It shows a lot less "Mud" than the 1080p @ 24 FPS video does of the same scene. The 720p file was @ 28 mb/sec. The 1080p @ 24 FPS file was at 22 mb/sec.

    I recorded the same wide angle scene with all of the resolutions. The 1080i was absolute garbage compared to the 1080p and 720p versions. It had the lowest bit rate though. Even with b-frames the 1080i still wasn't any good because its average bit rate was so low.

    I will try to post all of the sample files to Vimeo later today.
    Great 720p.jpg
    1280 x 1024 - 356K
    Bad 1080i.jpg
    1280 x 1024 - 332K
  • IF your having problems with VLC
    Splash lite is a free AVCHD player
    I find it works better than VLC

    http://mirillis.com/en/products/splash.html
  • Here are the ideal 720p settings files. I only changed the Encoder setting 1 for 720p and updated the MJPEG settings. Everything else was left unchecked.
    setb.zip
    282B
    GH2 Ptool.xlsx
    16K
  • @rigs

    Thanks but I need to get VLC working. Any help getting this working is very much appreciated. I can test a whole quicker if I get this fixed.
  • ok a couple of questions.

    so changing only encoder 1 to enable 720p/60 B frames REQUIRES a 24p file recorded first to be stable, correct?

    As I mentioned in the other thread, this seems like some kind of set-up sub routine is run when you record a 24p file and then when you run the 720p, the settings are carried over. I don't think this is something that is strictly in the encoder settings tables..

    Do you think the VLC problem is a player codec problem or could it be some problem with the camera codec non-conforming now that it's been modified?
  • @svart

    Try to use other settings.
    I suggest to try to adjust Video Buffer to make it equal to Video Buffer 24p value.
  • I plan to. Just trying to get things straight as the information is coming in from multiple threads and is changing as people test.
  • Try assigning a specific codec in vlc for gh2 files, you do this in preferences under external codecs. That will disable the vlc internal codecs for that type. For example you could assign Core Pro Codec
This topic is closed.
← All Discussions