Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
Can No Longer Install Panasonic Firmware
  • I am having the same problem with firmware not being able to be loaded. I took the following steps...

    Installed the 44 mbs patch. I named it GH2__V12.bin. It worked fine. I didn't notice a huge difference in quality.

    I then installed the 88mbs patch. I named it GH2__V13.bin. My current cards aren't fast enough to support it so I tried to load Panasonic's firware GH2_V11. The firware would not load.

    I then tried to reinstall the 44mbs patch and it worked.

    Now the camera won't recognize any firware when it's loaded.

    I have tried to load the panasonic firmware back multiple times. I've tried it named as GH2__V12.bin and GH2__V20 and GH2__V13

  • 5 Replies sorted by
  • It does not work because you name it incorrectly. It should be GH2_V12 NOT GH2__V12

  • @Montwood41 if you are saying you can't restore the stock firmware, I don't think you can just reflash with the stock firmware file (correct me if I'm wrong, someone).

    I think you have to run ptools with the original firmware, have no options selected apart from version increment, then save as a new file with a file name of your choice such as GH2__Vxx.bin (must have 2 underscores after the GH2 bit and xx is any two digits). Then flash with that new file. It will be the same as the original firmware but the camera will accept it. Let us know if that works.

    If you've already tried the above (ie via ptools) and it won't accept the new file, try resetting the camera settings in the camera menu.

  • sorry, my 2 year old posted here :))

  • That did the trick! Thanks so much for your help.