Personal View site logo
Make sure to join PV Telegram channel! Perfect to keep up with community on your smartphone.
Can't get GH2 to go to "BODY VERSION UP"
  • Hi, really like this website, I've been looking at it for a good while but today I've finally decide to hack my GH2. I've followed all the steps but just at the final part I cannot get it to update.

    I have the hack on the freshly formatted card but when I turn on the camera and press the green play button, it just says "NO VALID PICTURE TO PLAY", when I should really get the option of "BODY VERSION UP". I know it must be something simple I'm missing but any help would be great.

    Thanks a lot M

  • 8 Replies sorted by
  • Thanks a mil for getting back Hithemark, this is the guide that I was following and is really good, gives every detail needed but yeah, for some reason when I put the card in the camera and hit the green play button I just can't get it to update, it just tries to play a video, or photo that isn't there, as the card is freshly formatted and only contains the .bin file.

    I'll keep on experimenting with it but thanks a lot for the link, really appreciate it.

  • It sounds like the camera is not recognizing the file. Have you tried loading the original software ver 1.1 ? And more importantly, did you format the card in the camera? If you formatted in the computer you will run into Fat 32, NTFS, ExFat issues. Offhand, I forget which one the camera will recognize. I have tried many different Hacks on my Cam with no problems, I agree with you it's probably something simple. Also, what type of SDHC card are you using ?

  • Thanks again Hitthemark, really appreciate you taking the time to get back. I reformatted the card in the camera a few times with no luck at all but there are 2 things straight away that could be possible issues that you have mentioned.

    I haven't reloaded any of the original software on to the camera but when I go into Version Display on the actual camera, the Body Firmware and Lens Firmware says it's 1.1 on the camera, seems to be ok but might be worth trying to reload it onto the camera, I'll see if I can do that.

    And the card, I am using a micro SD in an SD adaptor, it's a good Sandisk Extreme one and the camera can read and recored to it fine but possibly that could be the issue.

    I'll experiment with it some more and let you know how I get on anyway, hopefully it will beneficial to any other new members too if I can figure out what the issue is and eliminate the problem.

    Many thanks again

  • It's possible the .bin file has not been hacked. Maybe try starting again. Download another original bin file and run Ptools, redo the hack settings and export a new .bin file. I tried a lot of different hack settings but never changed the name of the hacked .bin files, kept the same name as the original file. Keep track of the original .bin file and hacked .bin files by putting them in different folders. Check the SD card slot, does it read and write? , clean with compressed air.

  • @jleo

    nice thing to try is to use larger version increments.

  • Thanks for the help jleo and Vitaliy, I should get some time during the week week to try out all the suggestions. I'll get back and let you know what the issue is if I can crack it...

  • Hi guys, Just reporting back on the hacking, thanks a million for all the suggestions and help with this, really do appreciate it. Just managed to get the camera to update!! I did a few things different so it could be a number of things but I’m fairly sure it is step 1 that did it, either way it should be of help to anyone who is stuck in the same situation.

    1. Ok, so first thing I did was loaded GH2__V11.bin into the "Load Firmware" section, as Hitthemark suggested, I think this might be the most important change I made, as I think I had been using GH__V12.bin

    2. I used the A section to load the hack also, I had been working backward, using J, I, H for some reason but this is probably not too important

    3. I loaded a different hack also, Driftwood ‘Aquarius’ ver 2, this could be important but I’m fairly sure the first step is what did it

    4. Used the same card too, so micro SD to SD adapters don’t seem to cause any issues.

    So yeah, haven’t tried shooting anything yet but have read that nothing changes in the menus etc.. So yeah, all still looks the same. Main thing I am after is getting it to recored longer than 30 minutes really, so will test this hack and see how it works before I look at any others.

    Again, thanks a lot for all the help with this. M