Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
GH2 Hack Not Working, Solved
  • I tried to figure this out as much as I can before going to the forums. But I'm doing something wrong. I used to have a GH1 which I've hacked successfully numerous times. But something isn't going well for me in my attempt to hack the GH2.

    So here's what I did:


    1. Downloaded pTools 3.62D
    2. Downloaded base firmware
    3. Grabbed Driftwood patch


    (I first preformatted the card in-camera)

    1. I open pTools 3.62
    2. I load base firmware.
    3. I choose setting "B"
    4. I save firmware as GH2_V11.bin (original GH2_V10.bin)
    5. I load SD card with bin file in root directory.
    6. I press playback button.
    7. I get "No Valid Image to Display."

    When I did the same thing with my GH1, I would get the prompt if I wanted to version up.

    Any thoughts?
  • 3 Replies sorted by
  • problem solved. thank you. i don't know why, but it only worked when i saved the firmware to the camera by plugging it in through USB. I used to be able to plug it into my macbook SD card reader and dump the firmware there and put the card in the camera.
  • @ycabrera I don't know why this would be the case? Maybe there is a problem with your SD card reader you are using? (Macbook?) Maybe try using an external SD card reader to dump the firmware as a test?
This topic is closed.
← All Discussions