Personal View site logo
Best gear deals, direct from factories - CatchIt deals and Special deals. Also check Cameras, lenses, software, gear deals.
You support is vital for us. To keep this place ad free and independent, select one of the options below.
Donations are going to project support costs and work (hosting, etc).
I am spending good amount of time on it and your support allows to improve and expand this site.
contribution size
PTool 3.60d topic
  • 259 Replies sorted by
  • >I did over 60 tests today

    Do not rush.
    Plan that you do.
    Use always high detailed target (for bitrate tests).
  • @redsky Thanks

    I've saved the file successfully (GH2__V11.BIN) to the root directory of my SD card. The battery is completely charged , i press and hold the playback button (green arrow) and turn on the camera. And ..... nothing happens. The same when turning on the camera and pressing the play button. The displays turns on instantly. What i'm doing wrong? Nobody reported any problems here.
  • Is the GH2 original firmware not available on their website anymore?
  • It never was available from the Panasonic site if that's what you mean, it has leaked and people have been sharing it since
    http://www.mediafire.com/file/cwok7orwdegp2pg/GH2_V10E.zip
    http://www.filefactory.com/file/cc28149/n/GH2_V10E.zip
  • >Is the GH2 original firmware not available on their website anymore?

    Read second post in this topic. Panasonic never released GH2 firmware to public officially.
  • Great work Vitaliy. Any word on whether this can get a language change on Japanese GH2s?
  • man it's already on the patches, see the post
  • BRAVO !!!
  • Does this also work on the GF2 or is this totally different?
  • >Does this also work on the GF2 or is this totally different?

    Of course it is totally different.
  • Can i just point out
    Theres a lot of silly questions guys.
    If you do not know ptool or basic knowledge of what you are doing then dont hack your camera. You will run the risk of bricking your camera if you go in blind and tick any old box.
    Educate yourself first.
    Be patient.
    Its in early testing stage...so let testers who know what they are doing work their magic.
    Great work VK!
  • Great Mimirsan!! Even I get annoyed with the silly questions I can only imagine what Vitaliy feels!! hahaha
    Come on guys do your homework before poping a question!
    Good works for u Vitaliy and testers
    Your efforts are greatly appreciated
  • @Mimirsan

    First, silly questions are ok.
    Second, it is almost impossible to brick camera with wrong patches.
    May be 2-3% if you use ExTele cruicial patch (and it is in proper section and has special warning).
  • But be aware you can brick it if you don't use a fully charged battery.
  • >>> I've saved the file successfully (GH2__V11.BIN) to the root directory of my SD card. The battery is completely charged , i press and hold the playback button (green arrow) and turn on the camera. And ..... nothing happens. The same when turning on the camera and pressing the play button. The display turns on instantly. What i'm doing wrong? Nobody reported any problems here. <<<<<<br />
    Any suggestions?
  • Vitaliy
    Okay i thought it'll just clog the threads up and annoy you...but I understand the potential that someone who is asking silly question may provide results ;-)

    But some should research first when its explained clearly already and youre still going to get someone who will get overexcited and tick everything even the risky patches.

    ironic that I could clog this thread up with this so thats that haha
  • >i press and hold the playback button (green arrow) and turn on the camera. And ..... nothing happens

    It is always good to read first. You do not need to hold anything. Just turn in on and after it press play.
  • Well said Mimirsan. I accidently load ExTele patch and didn't brick the body thankfully. However I couldn't figure out the purpose of that patch. And right now, I have two silly problems one is when I record (AVCHD)1080i video output becomes so distorted like a bad codec eror(I use class10 SD). Second is after the hack shutter click button doesn't work. I mean can't move between shutter and aperture to control them. It stuck on the shutter. To be able to set the aperture I have to press Q.menu button then go to aperture. Finally, is it possible to get back to Original firmware after the manipulation. End of the the silly questions:-)
  • >Finally, is it possible to get back to Original firmware after the manipulation.

    Check only Version increment patch. And you'll have clean firmware without patches.

    >I accidently load ExTele patch and didn't brick the body thankfully. However I couldn't figure out the purpose of that patch.

    So, it is not cruicial anymore. :-)
    Purpose is as follows - under some modes (like HDMI plugged), etc, firmware reset ExTele setting.
    This patch is designed to bypass this reset.
  • "So, it is not cruicial anymore. :-)"

    Lol...

    I don`t understand, what I can do with the ExTele patch. My GH2 doesn`t reset the ExTele without Hack.
  • >My GH2 doesn`t reset the ExTele without Hack.

    Plug in HDMI monitor :-)
  • >> It is always good to read first. You do not need to hold anything. Just turn in on and after it press play.

    >>> "The same when turning on the camera and pressing the play button."

    Does not work. European GH2 bought just one week ago.
  • "Plug in HDMI monitor :-)"

    Oh thank you, this is the point:-)

  • >Does not work.

    Switch to Mode M and then push the play button. If the firmware is named correctly, it should start flashing after acception.
  • PTool 3.60d updated
    Like all minor updates previously it can be spotted by looking at the release date in the PTool title.

    It contains some minor fixes.

    More important is that Video bitrate patches have updated error checks elimination (note, that it is included only in 24H and FHD/SH patches).
This topic is closed.
← All Discussions