Personal View site logo
Make sure to join PV on Telegram or Facebook! Perfect to keep up with community on your smartphone.
Z-CAM E1 Camera 100 Mbps hack for 4K DCI (fw v0.31)
  • 370 Replies sorted by
  • Hack only Firmware 3.1 only the exact Size and fps Lower Fw Kills the Camera ...Overheat

  • @Bob_Hawk the 0.31 is the latest firmware, but are you saying that any other format besides 16:9 will make the camera overheat?

  • The hack only work with FW 0.31.--With the other FW you risk a frozen or Kill your cam

    The individual hack only change a very specific resolution. The cumulative hack only combines several resolutions.

    Find out for yourself which : Resolutions - Frame rate and formats hack supports .

    If you don't know exactly what you're doing with a hack, you risk turning your camera into a brick

  • Hi,

    I'm using the Z-cam E1 in astrophotography. It works well. The lower shutter speed is 8 seconds.

    Is it possible to lower this speed, down to 20 or 30 or 60 seconds (or more...) with a hack of the firmware 0.31?

    Thank you very much.

  • @storyboardcreativity Thanks so much for your awesome reverse engineering work!!

    I’m trying to squeeze every last drop of performance out of this camera. It’s challenging I’m not gonna lie!

    I used your UHD 4K 100Mbps script. It works well.

    There are still issues I have with the image coming from this camera. The color fidelity is very off - showing lots of pink and green splotches in the shadow areas. I noticed that this is a very noisy sensor and maybe this color artifact comes from their 3D noise reduction. I saw earlier in this thread that you were making progress with disabling that. Have you managed to do so? I think if the chroma noise was more uniform the artifact would be less noticeable.

    Also, I’m recording at 100 ISO, but I still get more sensor noise than I would expect at such a low ISO. Is the camera lying to me? I hope to get the sensor to record with no, to very low gain so that I can get back light using fast full frames lenses + speedbooster. Do you think you’d be able to investigate if we can get ISO less than 100?

    Here’s a video sample:

  • I sat down with a very sharp Cine Lens and did side by side comparisons and the noise I am getting with the 100 MPS hack is actually causing Image Quality degradation. I then denoised the 100 MPS video and the 60 MPS video looks better under 100% enlargement. I know a ton of work went into this and I am not trying to be disparaging but the Noise outweighs the extra 40MPS of information.

  • thanks for the test result with the noise, you are probably right. the sensor of the E1 sometimes gets over 50 C during operation, the iphone app shows the sensor temp, because every sensor is noisy higher temp-higher Noise ,Blackmagic Cams have better cooling .

    The 100mps makes itself felt drastically with movements and fast light changes by changing from a fixed 50 mps to a variable 100 mps. with static image without much movement you still have 50-60Mps with a lot of fast movements, it rises drastically to over 100Mps. Without mod, a lot of moving artifacts appear .

    the processor in the E1 is very limited in performance, so I reduce the noise reduction in the camera and move it to davinci resolve

  • That’s a good point about temperature. I haven’t tried the MJPEG encoding yet - it’s supposed to be much easier on the CPU, but maybe more harsh on the I/O since it’s way more bandwidth. Has anyone tried a VBR between 60-100 to see if there’s a sweet spot? Wonder if removing the case and adding a heat sink will allow for reliable 100mbps video...

    I have NR set to light, is there a way to disable it completely?

  • I have 3 Zcam E1 but One of my Z Cam E1 has a display defect, I've had it open a few times. its all standart not magic

    The sensor is in contact with the front part of the battery compartment with a simple thermal paste, which is ideal for the LIPOs.!!!

    I am currently in the process of converting them.

    Accu out of the case, Peltie element on the sensor, with heat pipe heat out of the case

    The processor is cooled with a copper sheet behind the display, in between is a sloppy thermal pad without air one of my E1 lacked the thermal pad,.

    The SD card limited to 100Mbs, a SanDisk Extreme Pro has a write speed: up to 90 * MB / sec !!!!!

    I like my 2 Zcam E1 still running but It is and remains an action cam with a 4/3 sensor with an internal 8 bit color and limited processor performance.

    great distance from the colour and image quality of my BMMCC with 10bit ProRes ..

    if you set the noise reduction to min and deactivate the lens correction and do it with davinci resolve, you will have gained more.

    check if the use of the HDMI output (1080P) at 4k is noticeable in the image quality

  • Yes the noise and ‘posterized’ color artifacts are seen in the HDMI monitor, so this tells me that it’s not the encoder issue. I think auto white balance was adding some aggressive color correction and clipping come colors. I have disabled AWB, noise reduction to light and ISO 100 in the video sample I posted above. It’s seems to do ok in that low light environment, but I’m using a full-frame lens with a speed booster - probably at f1.4 or less effectively.

    I’m still curious about trying a bitrate of 85mbps or something

  • One method of reducing noise is to cool the camera. Generally, it will assumed that the thermal noise of a CMOS sensor with a temperature reduction is already halved by 7 ° C.

  • @Bob_Hawk

    E1 design is horrible regarding cooling, and comes from core team expirience (at the time) as they mostly designed OEM barebones action cameras (as samples to manufacturers) at Ambarella.

  • Are we 100% sure that cooling is the reason for these weird color effects that I'm seeing? I've attached a sample video. The effect I'm referring to is on the baby's arm. It looks like the color depth is reduced or "posterized" to just few shades. There isn't much noise anywhere else in the video beyond what I'd expect.

  • Here's the video I was referring to above: https://vimeo.com/user91667195/review/436677331/3ff364fa15 Vimeo doesn't seem to keep the original version anymore, but hopefully you can see what I'm talking about.

  • @ Vitaly-Kislev

    probably not developed rather changed and slimmed down so that it doesn't stand out Unfortunately Zcam has changed the BF1 design on Zcam E1 with Sony "IMX159" to the panasonic sensor for cost reasons, to return to Sony "IMX159" with the Zcam C1, unfortunately this backward innovation was then officially discontinued in favor of the E2 the development was not end because it was still used in stereo and multikam systems

  • Anyone who knows the history and development Zcam E1 will recognize the limits of the E1

    The start of Zcam is possible by meeting:

    1. E1 (BF1) an innovative product
    2. Jason Zhang an innovative developer
    3. Kinson Loo a brilliant marketing manager

    the rest is history

    I Love all my 3 x Zcam E1 - and 1x BMPCC4k 2 x BMMCC amd my Olympus E1 II

  • @Bob_Hawk

    OK, lets go back almost 2 years in time, and Kinson Loo a brilliant marketing manager :-)

    At the time they decided to go after cinema cameras market, instead of focusing on smaller, smarter cameras, especially suitable also for direct connection to computer (read games streamers, conference cam, and so on). And they did not want to hear anything, no arguments.

    Note that almost all team expertise had been Ambarella processors and not the chips they use now.

    Now they have amazing community and lot of good products (in small niche!), but as business goals are - Kinson decision had been badly wrong. They also abandoned almost all E1 users base (same error that Panasonic made gradually).

    Actually all this webcamera drivers craze (Z-CAM also participated in this) already showed how right my position had been.

  • Vitali-Kislev I've been a fan of the GF3 since your hack and fully agree with your criticism. I referred to E1 at kinson I am currently using 3 Zcam e1 and looking for 2 more. only through the hack can the e1 be used properly.

    Since the E2, zcam has been trying to shine with special functions and new extreme data . the result is an unmanageable number of resolutions and special functions and codec mix. For professionals it may be great if no normal mortal person knows about the confusion of codec resolutions, LUT and frame rate. The thermal design and the delusion of constantly overclocking the sensors constantly requires external software to hide the defects.

    strange that I have never wished for a hack with my blackmagic cameras, You have a logical menu and all resolutions simply work cleanly without stress.

    After I had the opportunity to test an E2, I immediately decided on the BMCC4k and I did not regret the decision.

    turn on . 30sec. set and film ...... Plug and Play

  • Back to E1

    The case mod goes into the next phase

    1.) Remove accu, cut out direction to sensor for peltie element

    2.) heat to the outside with a laptop cooler with heat pipe on the outside cooler

    First test :Cool the sensor to 15-20 C to avoid condensation. This works very precisely at + - 0.5C

    Second test : measured temperature of the "On Chip temp sensor" reduced from 42 C to 17C

    On photo´s you can immediately see a drastic reduction in noise

    "Noise that does not arise does not have to be removed"

    A friend is currently using the 3D data from the E2 to adapt a housing for 3D printing

    If that fits send it to printed in metal 3D

  • I have a Z CAM E1 that I have put through the ringer. It's screen is cracked, and the power plug port no longer works, so that has rendered it unusable to me.

    However, I figured for the right person this camera could still be of value. If you use these as a locked off cam somewhere in your set up or studio, then you could have this one for $10 to cover my time, plus whatever it costs to ship it to you. I've got it packed up in it's original box and ready to go.

    You would need the battery charger which you can buy directly from Z Cam for $40. This way you can charge the batteries externally, then slip them in the camera.

    All the buttons and wifi/remote control work perfectly fine. Sorry for not posting this in the For Sale section, I just wanted to get it in front of the right audience.

    Let me know if you're interested!

    Just didn't want to throw it in a landfill. Thanks

    IMG_4957.jpg
    4032 x 3024 - 1M
  • @orey10m

    Jepp Deal i send you a private mail

  • Firstable, Thank a lot for these effort and wonderful work. I have a problem with the script for 1080p 25ips. Cam start to record, but after 5s time meter freeze and I cannot stop recording, it stops some second after. Do someone else has same problem?? Thanks Hugues

  • 1.) Have you Firmware 0.31 ?
    2.) Use the cumulativ Hack ? 3.) the temperature of the housing rises ? 4.) What SD Card .

    Best result with SANDISK Extreme PRO 64 or 128 gig

  • New try today and at 1080p25, with the script, image freeze after 3sec!! Any advice?

  • Thanks Bob Hawk! My card is SanDisk Extreme 128G (not pro)